[Swift] UserDefault キーがすでに存在するか確認したい時

ITSwift

公式ドキュメントに UserDefaultsクラスのobjectメソッドは

「キーがなかったら、nil を返す」とありますので、

https://developer.apple.com/documentation/foundation/userdefaults/1410095-object

この書き方が良さげです。

extension UserDefaults {
    func contains(key: String) -> Bool {
        return UserDefaults.standard.object(forKey: key) != nil
    }
}

引用元:
https://stackoverflow.com/questions/25104700/check-if-userdefault-exists-swift#

contains っていう名前がシンプルで一番いいんと違いますかね。

スポンサーリンク

Posted by nobuhiro harada